Funkcja INDEKS pozwoli wyszukać najczęściej występującą nazwę

Autor: Dana Haralambie
W trakcie pracy w Excelu warto wykorzystać funkcję INDEKS, aby dokonywać zaawansowanych wyszukiwań w arkuszu. Doskonale łączy się ona w formułach z innymi funkcjami arkuszowymi: statystycznymi, czy logicznymi.
Załóżmy, że rejestrujemy zamówienia na produkty naszej firmy. Chcemy szybko sprawdzić, który z nich zamawiany był najczęściej, a który najrzadziej. Aby się o tym przekonać, wcale nie musimy filtrować zestawienia i zliczać poszczególnych pozycji. Jest szybszy sposób.
Rys. 1. Przykładowe zestawienie sprzedaży towarów
Aby odszukać produkt najczęściej pojawiający się w kolumnie B:
 
1. W komórce D2 wpisujemy następującą formułę:
=INDEKS(B2:B12;PODAJ.POZYCJĘ
(MAX(LICZ.JEŻELI(B2:B12;B2:B12));
LICZ.JEŻELI(B2:B12;B2:B12);0))
2. Koniecznie zatwierdzamy ją kombinacją klawiszy Ctrl + Shift + Enter, ponieważ jest to formuła tablicowa.
Uwaga
Jeśli wyedytujemy formułę, to musimy ją zawsze zatwierdzić wspomnianą kombinacją klawiszy. Poprawnie wprowadzona formuła tablicowa zostanie ujęta w nawiasy klamrowe widoczne na pasku formuły.
Nazwa produktu, który był najczęściej zamawiany, zostanie odnaleziona jak na rysunku 2.
Rys. 2. Najczęściej zamawiany produkt został odnaleziony
Teraz, aby odszukać najrzadziej zamawiany produkt:
 
1. W komórce E2 wprowadzamy bardzo podobną formułę tablicową:
=INDEKS(B2:B12;PODAJ.POZYCJĘ
(MIN(LICZ.JEŻELI(B2:B12;B2:B12));
LICZ.JEŻELI(B2:B12;B2:B12);0))
Rys. 3. Produkt 4 był najrzadziej sprzedawany
Uwaga
Jeżeli na liście występują dwie wartości pojawiające się równie często lub równie rzadko, obie formuły wskazujemy tą, która figuruje w kolumnie jako pierwsza.
Wyjaśnienie działania formuł:
Formuły różnią się jedynie nazwami dwóch użytych funkcji (MAX i MIN) pełniących inne zadania przy obliczeniach. Funkcje LICZ.JEŻELI mają za zadanie zliczenie, ile razy każdy towar występuje w zakresie komórek B2:B12. Funkcja MAX lub MIN wybiera odpowiednio największą lub najmniejszą wartość z uzyskanej tablicy wartości. Funkcja PODAJ.POZYCJĘ zwróci pozycję, na której znajduje się nazwa towaru odpowiadająca największej lub najmniejszej liczbie wystąpień i przekaże ją funkcji INDEKS.
 

Zobacz także:

Funkcja logiczna LUB rozszerzy możliwości funkcji JEŻELI
Źródło: https://www.poradykomputerowe.pl/tagi

Wykres przedziałów czasowych w Excelu
Źródło: https://www.poradykomputerowe.pl/tagi

Filtrowanie wg płci w Excelu
Źródło: https://www.poradykomputerowe.pl/tagi

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Skuteczne narzędzia do wykrywania uszkodzonych podzespołów

pobierz

Wykrywanie i usuwanie niechcianych programów

pobierz

Polecane artykuły


Polecamy