Funkcja logiczna LUB rozszerzy możliwości funkcji JEŻELI

Autor: Dana Haralambie
W budowanych przez nas formułach opartych na funkcji JEŻELI musimy nierzadko umieszczać wiele warunków. Funkcja LUB pozwoli na łatwiejsze tworzenie obliczeń uzależnionych od dużej liczby kryteriów.
Sposób działania formuły opartej na funkcjach JEŻELI oraz LUB sprawdźmy na prostym przykładzie. Przyjmijmy, że zgromadziliśmy w tabeli wyniki finansowe poszczególnych oddziałów. Potrzebujemy szybko sprawdzić, czy w którymś miesiącu jeden z oddziałów miał straty.
Rys. 1. Przykładowe dane
W tym celu:
 
1. Do komórki B8 wprowadzamy następującą formułę:
=JEŻELI(LUB(B2<0;B3<0;B4<0;B5<0;B6<0;B7<0);
"Strata";"Tylko zyski")
2. Skopiujmy ją w prawo do kolejnych kolumn.
Rys. 2. Formuła zwróciła poprawne wyniki
Funkcja LUB sprawdza warunki zawarte w poszczególnych argumentach (może ich być nawet 30) i zwraca wartość PRAWDA, jeżeli przynajmniej jeden z nich zwraca wartość PRAWDA. Jeśli wszystkie warunki dają w wyniku FAŁSZ, wtedy wynikiem działania formuły jest FAŁSZ.
Wskazówka
Użytkownicy wersji Excela wcześniejszych niż 2007 napotkają kłopot, z którego może wybawić ich funkcja LUB. Otóż w starszych wydaniach arkusza kalkulacyjnego w funkcji JEŻELI można zagnieździć maksymalnie 7 warunków. Dzięki zastosowaniu funkcji LUB ograniczenie znika.
 

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Skuteczne narzędzia do wykrywania uszkodzonych podzespołów

pobierz

Wykrywanie i usuwanie niechcianych programów

pobierz

Polecane artykuły


Polecamy