Sprawdzanie poprawności danych w rejestrach

Wpisywanie danych nienależących do określonej grupy jest niepożądane, ponieważ może zaburzyć spójność zestawienia, a przez to analizę danych uczynić trudniejszą. Aby uniknąć nieprawidłowości, proponujemy zastosować narzędzie Excela o nazwie Sprawdzanie poprawności danych.
 

Rys. 1. Przykładowe zestawienie, do którego będą dopisywane nowe wartości
 
W kolumnie A, a dokładniej w zakresie A2:A20 możliwe będzie wpisanie nazwy produktu, która już występuje powyżej.
Aby uzyskać taki efekt:
   1. Zaznacz zakres komórek A2:A20 i z menu Dane wybierz polecenie Sprawdzanie poprawności (w Excelu 2007/2010: uaktywnij kartę Dane i w grupie poleceń Narzędzia danych kliknij Poprawność danych).
2. W wyświetlonym oknie przejdź do zakładki Ustawienia.
3. Z rozwijanej listy Dozwolone wybierz pozycję Niestandardowe.
4. W polu poniżej wprowadź następującą formułę:
=LICZ.JEŻELI(A$2:A$20;A2)>1
Rys. 2. Ustawienia sprawdzania poprawności danych
 
5. Zatwierdź, klikając OK.
Od tego momentu przy próbie wprowadzenia nazwy produktu, której nie ma na liście powyżej, zostanie wyświetlone okno dialogowe z ostrzeżeniem o nieprawidłowej wartości.
Rys. 3. Wpis jest niedozwolony

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Skuteczne narzędzia do wykrywania uszkodzonych podzespołów

pobierz

Wykrywanie i usuwanie niechcianych programów

pobierz

Polecane artykuły


Polecamy