Szybka suma sprzedaży z podziałem na produkty

Potrzebujesz sporządzić raport, który będzie zawierał podsumowanie sprzedaży poszczególnych produktów. Do wykonania takiego zadania możesz posłużyć się różnymi narzędziami analitycznymi Excela (np. tabelami przestawnymi czy sumami częściowymi). Jeżeli jednak wolisz korzystać z formuł, użyj funkcji SUMA.JEŻELI, która świetnie się sprawdza w tego typu zadaniach.
  
Fragment przykładowego zestawienia sprzedaży, które obejmuje zakres komórek A1:B20, przedstawia rysunek 1.
Rys. 1. Dane sprzedażowe
 
=> Aby wykonać obliczenia:
1. W pierwszej kolejności obok zestawienia sprzedaży zbuduj tabelę pomocniczą, w której zostaną wyświetlone wyniki działania formuł. Wpisz do niej nazwy wszystkich produktów, które występują na liście.
Rys. 2. Tabela pomocnicza, do której wprowadzisz formuły sumujące
2. Możesz teraz przystąpić do wykonania obliczeń. W komórce E2 wprowadź formułę:
=SUMA.JEŻELI($A$2:$B$20;D2;$B$2:$B$20)
3. Skopiuj ją do komórek poniżej, klikając dwukrotnie prawy dolny róg komórki z formułą (tzw. uchwyt wypełnienia).
Uzyskasz efekt jak na rysunku 3.
 
Rys. 3. Formuła zwróciła poprawne sumy dla wszystkich produktów
Wyjaśnienie działania formuły:
Funkcja SUMA.JEŻELI sumuje wartości z komórek, które spełniają określone kryterium.
- Argument pierwszy zawiera zakres komórek, które mają być sprawdzone pod kątem zgodności z kryterium zawartym w argumencie drugim ($A$2:$B$20). Zauważ, że zakres obejmuje zarówno nazwy wszystkich produktów (kryteria), jak i kwoty do zsumowania.
- Argument drugi (D2) to kryterium, pod kątem którego mają być sumowane kwoty z kolumny C. Zamiast odwołania do komórki możesz także użyć nazwy produktu. Pamiętaj jednak, aby ująć ją w cudzysłów, gdyż jest to wartość tekstowa [($A$2:$B$20;"Skaner";$B$2:$B$20)].
- Argument trzeci to zakres komórek, w którym znajdują się kwoty do zsumowania.
W ten szybki sposób uzyskałeś podsumowania sprzedaży poszczególnych produktów. Zwróć uwagę, że dla argumentów pierwszego i trzeciego zastosowano adresowanie bezwzględne. Pozwala to uzyskać poprawne wyniki w miarę kopiowania formuły w dół.

Zaloguj się, aby dodać komentarz

Nie masz konta? Zarejestruj się »

Zobacz także

Skuteczne narzędzia do wykrywania uszkodzonych podzespołów

pobierz

Wykrywanie i usuwanie niechcianych programów

pobierz

Polecane artykuły


Polecamy